Author Topic: Game crashes on new game  (Read 621 times)

captainradish

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Game crashes on new game
« on: September 01, 2015, 05:00:52 PM »
I played the tutorial without any problems but I cannot start a new game. It crashes every single time after the screen where I change races and options. The error log has nothing in it and the other log simply has this:

01 Sep 2015 17:37:50
Initializing sound
Initializing window system
Loading engine settings
Initializing OpenGL Engine
Registering mods
Starting 7 threads on 6 processors.
Loading mod(s)
OpenGL vendor 'ATI Technologies Inc.', renderer 'AMD Radeon HD 6700 Series'
       version '4.5.13399 Compatibility Profile Context 15.200.1062.1004'
Loaded in 5.9 seconds
Shadow scripts: 263ms load, 2389ms compile
Server scripts: 266ms load, 4712ms compile
Client scripts: 273ms load, 6762ms compile
Loaded in 7.1 seconds

If I run it with -verbose i get this:

01 Sep 2015 18:50:17
Initializing sound
Initializing window system
Loading engine settings
Initializing OpenGL Engine
Registering mods
Starting 7 threads on 6 processors.
Loading mod(s)
CloudInit started at 0.0s on thread 7
Preparing tasks took 0.2 ms
CloudInit took 128.3ms on thread 7
CloudMods started at 0.1s on thread 1
CloudFiles started at 0.1s on thread 8
CloudFiles took 1.4ms on thread 8
CloudMods took 226.2ms on thread 1
ModInit started at 0.4s on thread 20
ModInit took 29.9ms on thread 20
LocateScripts started at 0.4s on thread 1
GameConfig started at 0.4s on thread 7
Effects started at 0.4s on thread 6
EmpireStats started at 0.4s on thread 19
ObjectTypes started at 0.4s on thread 8
EmpireStats took 0.7ms on thread 19
GameConfig took 1.1ms on thread 7
Shaders started at 0.4s on thread 20
ObjectTypes took 1.9ms on thread 8
Effects took 2.0ms on thread 6
Fonts started at 0.4s on thread 7
Sounds started at 0.4s on thread 19
Models started at 0.4s on thread 8
Generics started at 0.4s on thread 6
Generics took 0.2ms on thread 6
NodeTypes started at 0.4s on thread 6
NodeTypes took 1.0ms on thread 6
Components started at 0.4s on thread 6
Sounds took 9.9ms on thread 19
Shaders took 18.5ms on thread 20
Effectors started at 0.4s on thread 20
Models took 22.1ms on thread 8
Components took 17.1ms on thread 6
Materials started at 0.4s on thread 8
Effectors took 4.4ms on thread 20
Events started at 0.4s on thread 20
Events took 4.6ms on thread 20
ProcessSounds started at 0.4s on thread 19
ProcessSounds took 0.0ms on thread 19
States started at 0.5s on thread 20
States took 3.0ms on thread 20
ObjComponentOffsets started at 0.5s on thread 19
ObjComponentOffsets took 0.1ms on thread 19
SubSystems started at 0.5s on thread 20
LocateScripts took 82.2ms on thread 1
Window started at 0.5s on thread 1
ShaderStateVars started at 0.5s on thread 19
ShaderStateVars took 0.0ms on thread 19
PreloadScripts started at 0.5s on thread 19
PreloadScripts took 0.3ms on thread 19
Materials took 73.8ms on thread 8
Particles started at 0.7s on thread 19
Particles took 14.2ms on thread 19
SubSystems took 224.9ms on thread 20
ResourceBinds started at 0.8s on thread 19
ResourceBinds took 0.1ms on thread 19
Shipsets started at 0.8s on thread 20
Fonts took 492.4ms on thread 7
SkinStyles started at 1.1s on thread 7
SkinStyles took 7.4ms on thread 7
MaterialBinds started at 1.1s on thread 7
MaterialBinds took 0.5ms on thread 7
Shipsets took 377.4ms on thread 20
MenuScripts started at 1.2s on thread 7
OpenGL vendor 'ATI Technologies Inc.', renderer 'AMD Radeon HD 6700 Series'
       version '4.5.13399 Compatibility Profile Context 15.200.1062.1004'
Window took 2113.4ms on thread 1
Errors started at 2.6s on thread 1
Errors took 7.0ms on thread 1
CompileShaders started at 2.6s on thread 1
ProcessImages started at 2.7s on thread 19
ProcessImages took 54.4ms on thread 19
CompileShaders took 137.7ms on thread 1
ProcessTextures started at 2.7s on thread 1
ProcessTextures took 27.7ms on thread 1
ProcessModels started at 2.8s on thread 1
ProcessModels took 54.1ms on thread 1
MenuScripts took 3781.7ms on thread 7
Loaded in 5.0 seconds
Tasks used a total of 7.9 seconds (58% faster)
Preparing tasks took 0.2 ms
ServerScripts started at 0.0s on thread 99
ShadowScripts started at 0.0s on thread 100
ClientScripts started at 0.0s on thread 101
ProcessImages started at 0.0s on thread 102
ProcessSounds started at 0.0s on thread 103
ProcessSounds took 0.1ms on thread 103
ProcessImages took 456.1ms on thread 102
Shadow scripts: 341ms load, 2150ms compile
ShadowScripts took 2491.9ms on thread 100
Server scripts: 203ms load, 4251ms compile
ServerScripts took 4455.1ms on thread 99
Client scripts: 193ms load, 5578ms compile
ClientScripts took 5772.0ms on thread 101
CleanupScripts started at 5.8s on thread 103
CleanupScripts took 13.6ms on thread 103
Loaded in 5.8 seconds
Tasks used a total of 13.2 seconds (127% faster)
Map generation: 416.7ms
Link generation: 0.1ms
Elevation grid took 12ms to calculate.

Any help would be appreciated. I really enjoyed Star Ruler 1 and want to play SR2.
« Last Edit: September 01, 2015, 06:05:14 PM by captainradish »

dalolorn

  • Sentient
  • **
  • Posts: 199
  • Karma: +7/-0
  • ABEM Developer
    • View Profile
Re: Game crashes on new game
« Reply #1 on: September 02, 2015, 04:31:37 AM »
Compatibility profile? That doesn't sound good.

Try disabling any compatibility settings your OS or other software may have automatically enabled.