Author Topic: Repeated Crashing since 1.0.7.0  (Read 4880 times)

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Repeated Crashing since 1.0.7.0
« on: April 10, 2011, 05:02:56 PM »
To anyone experience crashing issues since updating to 1.0.7.0, we have identified two common fixes:

Steam Users: Verify Star Ruler's files. If that doesn't work, also try...

All Users: Make a backup of your User Files (Found in "My Documents/My Games/Star Ruler"), then delete the contents of the folder. Most files can be safely restored into this folder if the fix works.

Zonerider

  • Newbie
  • *
  • Posts: 13
  • Karma: +1/-0
    • View Profile
Re: Repeated Crashing since 1.0.7.0
« Reply #1 on: April 16, 2011, 06:15:32 PM »
I have try all the tipps, but star ruler AND the new demo dont run! Crashed in less minutes. I have start a new game in the full version at tech 28 and build 3 thrusters on my planet, build 3 ringworlds in the systems around, save the game, load and become a "invald saved effect stats". In the demo i try to take over 2 systems, the game chrashed... and steam lets me not install a erlier patch. 

:'( please fix that oh holy programmer.

Mecos

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Repeated Crashing since 1.0.7.0
« Reply #2 on: May 15, 2011, 01:08:21 PM »
I have this problem as well..  :(

Just got the game.. played it 4 times.. or tried rather.

System:
I7 950 quad core 3.07 
12 gig of Ram
2 gig vid card (Zotac Geforce GTX 580)
all the latest drivers
The system is able to play Crisis2 in full render without issues or lag.

When playing Star Ruler the computer runs at about 18% of its capability. and yet.. when I prep for a large battle and send off 1000 or so ships.. it crashes before or during engagement.. on all 4 times I played.. all new game start over with settings turned down to max the performance resourses..

I have tried the above recomendation for 2 of the new game starts.. but the issue remains..

can we expect a 1.0.7.6 anytime soon that resolves this? 

*Game shelved till repaired.*

Thank You for your time.

Mecos

« Last Edit: May 15, 2011, 01:12:21 PM by Mecos »

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: Repeated Crashing since 1.0.7.0
« Reply #3 on: May 15, 2011, 01:37:45 PM »
There were a number of crashes that have been fixed for 1.0.7.6, which is due out quite soon.

Grooovie

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Repeated Crashing since 1.0.7.0
« Reply #4 on: November 03, 2011, 10:36:03 AM »
Ok I did the demo, but I restarted a new game, then I didnt have any AI players, so I bought the game.
I started a game x 10, and every time after a couple of minutes when I right-click or give an order the game crasher.
This game is super instable. I am rather dissappointed. It looks promishing.
I did the steam cash procedure. It didn't help.

Firgof

  • BMS Administrator
  • Delusional
  • *
  • Posts: 1531
  • Karma: +175/-4
    • View Profile
Re: Repeated Crashing since 1.0.7.0
« Reply #5 on: November 03, 2011, 10:49:46 AM »
I bet something went wrong with your install.  Could you post a copy of your log.txt after you experience such a crash?  It's located in your User Files (My Documents/My Games/Star Ruler/)
"Now it will punish you"

Risbo

  • Newbie
  • *
  • Posts: 31
  • Karma: +0/-0
    • View Profile
Re: Repeated Crashing since 1.0.7.0
« Reply #6 on: March 16, 2012, 09:36:09 PM »
I got the issue too can't wait for next patch =) (can't play for now... i posted in the forum a while ago)

MrRogers

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Repeated Crashing since 1.0.7.0
« Reply #7 on: March 26, 2012, 02:27:48 PM »
Was the update given to steam? Because I bought this game Saturday, and I am experiencing crashes whenever I try to scroll in the race editing menus, and also when I try to make treaties. I also got one when I clicked on a planet and clicked the "orders" button in the bottom middle menu that showed up. Also, when I alt-mouse over a ship to view the range, I got a pink and black checked box. I tried verifying my files with steam, and that worked fine, but nothing changed. I also redownloaded and reinstalled.

Firgof

  • BMS Administrator
  • Delusional
  • *
  • Posts: 1531
  • Karma: +175/-4
    • View Profile
Re: Repeated Crashing since 1.0.7.0
« Reply #8 on: March 26, 2012, 02:43:42 PM »
It has not as our contact has not returned from vacation yet.  Due to this, the patch is not available on Steam.
"Now it will punish you"

Flare

  • Newbie
  • *
  • Posts: 32
  • Karma: +1/-0
    • View Profile
Re: Repeated Crashing since 1.0.7.0
« Reply #9 on: February 10, 2013, 08:43:25 AM »
All Users: Make a backup of your User Files (Found in "My Documents/My Games/Star Ruler"), then delete the contents of the folder. Most files can be safely restored into this folder if the fix works.

So what I do is copy the star ruler file inside of my documents to some other place, and then delete the original star ruler file. After that is done, I just most the copied star ruler file into the same place?