Author Topic: [ATI Users] Disable Catalyst AI  (Read 20645 times)

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
[ATI Users] Disable Catalyst AI
« on: September 30, 2010, 02:44:50 PM »
On some ATI cards, various transparent elements do not render, or render improperly. As a workaround, we suggest disabling Catalyst AI in your ATI control panel.

You may also need to downgrade to an older driver. Driver version 10.4 has been reported as working well with Star Ruler.
« Last Edit: July 17, 2011, 12:11:31 PM by Thy Reaper »

Interceptor

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #1 on: November 01, 2010, 09:05:55 AM »
yeah, on my computer it actually uninstalled my driver, and wouldn't let me reinstall it. some sort of bug there. i ended up finally getting it to install, but now every few hours of game time it will say "StarRuler.exe has stopped working" and i have to quit and restart. any time i go back to that game, it does the same thing in a few seconds. could this be because of ATI?

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: [ATI Users] Disable Catalyst AI
« Reply #2 on: November 02, 2010, 05:40:14 PM »
I have no idea how you managed to uninstall your driver? The Catalyst AI is a setting in the control panel, and should have no power to uninstall anything.

Interceptor

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #3 on: November 04, 2010, 05:17:24 PM »
No, i mean something in the game startup did this. I've been having problems with games on disks uninstalling or deleting integral windows operating files sometimes, not sure what the problem is. but the first time i started this up, it uninstalled my driver. i reinstalled it and it was fine.. maybe just coincidence?

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: [ATI Users] Disable Catalyst AI
« Reply #4 on: November 06, 2010, 04:57:50 AM »
Star Ruler can't affect your system in that way. Something must be wrong with your OS.

ouch

  • Distracted
  • ***
  • Posts: 216
  • Karma: +17/-1
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #5 on: November 06, 2010, 02:58:43 PM »
More likely a problem with the hard drive. Sounds simular to corrupted file tables. If so, your OS doesn't know when some files begin or end. As a result new files overlap (therby over writing) the old ones. Your hardrive might be fine, but your OS glitched while writing a file awhile back, or perhaps even while installing Star Ruler.

I'd run chkdsk /f if I were you. The longer you let this go the more damage will be caused if you do infact have this issue.
My Mods:
Auto Resource Transfering Subsystems (Fuel, Power, Ammo):
http://forums.blind-mind.com/index.php?topic=1427.0
Advanced spiral universe generation:
http://forums.blind-mind.com/index.php?topic=1536.0
Currently working on: Adv Spiral Universe Map

Interceptor

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #6 on: November 06, 2010, 04:41:56 PM »
Yes, problems with the OS have been happening well before star ruler. and how would I run that program? (bear in mind i'm not exactly a computer programmer lol)

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: [ATI Users] Disable Catalyst AI
« Reply #7 on: November 06, 2010, 05:33:10 PM »
In Start Menu, find run. In the box that pops up, type cmd and run that. In that window, type chkdsk /f, and press enter. If you are on Vista or Windows 7 you will have to run cmd as an administrator (which you can do by searching cmd in the start menu, right clicking on the program in the list, and selecting Run as Administrator).

Interceptor

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #8 on: November 09, 2010, 10:32:05 PM »
"Chkdsk cannot run because the volume is in use by another process." I had exited all other windows and applications at this point. what does this message mean?

and thanks man, i know this doesn't really pertain to the game, but it's really helping me out

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: [ATI Users] Disable Catalyst AI
« Reply #9 on: November 10, 2010, 01:01:28 AM »
It would have to schedule it to run when you next boot. It's best to look up specific help on chkdsk through google or something at this point, as I don't have much experience with it.

ouch

  • Distracted
  • ***
  • Posts: 216
  • Karma: +17/-1
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #10 on: November 10, 2010, 02:52:23 AM »
first off, what windows version are you using anyway?
My Mods:
Auto Resource Transfering Subsystems (Fuel, Power, Ammo):
http://forums.blind-mind.com/index.php?topic=1427.0
Advanced spiral universe generation:
http://forums.blind-mind.com/index.php?topic=1536.0
Currently working on: Adv Spiral Universe Map

Interceptor

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #11 on: November 10, 2010, 07:33:42 AM »
ok, got it to work, but didn't really understand the billions of lines of text that flew past on my screen. when i got to the main desktop page after rebooting and the check, no messages or anything showed up telling of my results.

And i have Windows 7, forgot what edition

Xplodzion

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #12 on: November 26, 2010, 04:07:51 AM »
The latest ATI Drivers don't seem to let you disable the Catalyst AI anymore, they've changed the way it works.



From what I know that surface format optimisation was on by default before the change which is what may have been causing the issues, I keep it off by default now that it lets you modify it as it makes Anisotropic filtering look alot better.

I'm using a HD5850 and don't appear to have any graphical issues, but I only bought Star Ruler recently so for all I know something could be broken but I'm not noticing the difference.
« Last Edit: November 26, 2010, 04:12:49 AM by Xplodzion »

Mad Mac19

  • Newbie
  • *
  • Posts: 37
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #13 on: November 26, 2010, 04:46:54 AM »
move the slider to the left if i remember right it have high AI low AI and then none AI....
sorry for my bad english^^ i try to get better...

Xplodzion

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #14 on: November 26, 2010, 05:11:25 AM »
move the slider to the left if i remember right it have high AI low AI and then none AI....

That sets it to performance now, there's no off setting.

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: [ATI Users] Disable Catalyst AI
« Reply #15 on: November 26, 2010, 05:23:33 AM »
Performance is often disabled, or at least set to a lower setting of some sort (Standard or Off - both of which seem to work with Star Ruler - would be performance, Advanced would be quality).

Brainlost

  • Newbie
  • *
  • Posts: 1
  • Karma: +1/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #16 on: December 04, 2010, 12:07:33 PM »
The Catalyst AI can be disabled in the Taskbar.

cynric

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-3
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #17 on: April 22, 2011, 08:59:00 PM »
I can't say it enough, thanks for making a great game.

I have noticed that randomly the graphics will change from sparse to good. ie. Whenever I start a game it never shows travel lines, ship/planet icons do not enlarge when selected like if I group them to a hot key. but if I save the game and come back, sometimes everything starts working sometimes it dosn't. The game is still playable but It does help to see my fleets destinations when I have a bunch of em. I have tried to disable my Catalyst A.I. but I do not have a Win Icon to use to disable it, so I have set it to performance with Optimizaion off.
Also out of curiosity any ETA on when the ATI catalsty thing will be changed from work around to resolved?

GGLucas

  • Dr. Evil
  • BMS Staff
  • Delusional
  • *
  • Posts: 1877
  • Karma: +300/-6
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #18 on: April 23, 2011, 03:29:50 AM »
The catalyst AI is a nonstandard feature. If anything the ATI drivers are buggy, there is nothing we can do about it.

None of us have ATI cards either, so there's no way to figure out what exactly triggers the bug in the ATI drivers.

cynric

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-3
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #19 on: April 24, 2011, 06:57:17 PM »
Please don't think me ungrateful for everything you guys have done in this game genre, however thats the kind of response I would expect from a large corporation, not a bunch of great guys that work with there game users. I remember when Defense Grid came out, for like 6 months most ppl didn't have sound, they kept blaming microsoft, I use the same logic on you i used on them, how does every other game manufacturer make it work? You say ATI is buggy and none of you have ATI cards so you say there is NO way to figure out exactly what triggers the bug. I say there is a way, but you do not want to go through the effort of fixing it. Which is also understandable, you don't use ATI so those of us that do are SOL. You will say its ATI, ATI will say its you, i've seen this kind of buck passing too many times.

Great game, wish I could play it, but I will give up my ATI card when Hell Freezes over, I have 100's of games and every single one works fine on my system. I'll keep checking back every 6 months or so till a fix is found, then hopefully I can play this game.

To be constructive so this dosn't come off as a rant, perhaps in the future a response to a fix that is currently in the Don't know hot to fix it category should never be said It Can't Be Fixed, but instead should be said, we do not know how to fix it at this time, but we Are investigating how to fix it. Keep those logs coming in to help us. Who knows maybe you guys will put together an ATI system just for bug testing, it could happen.

GGLucas

  • Dr. Evil
  • BMS Staff
  • Delusional
  • *
  • Posts: 1877
  • Karma: +300/-6
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #20 on: April 24, 2011, 07:06:05 PM »
Quote
thats the kind of response I would expect from a large corporation

It's also the truth, so I'm not sure what you're getting at here.

Quote
I say there is a way, but you do not want to go through the effort of fixing it.

I would love to hear your way of fixing it, it would be implemented instantly.

Quote
You will say its ATI, ATI will say its you, i've seen this kind of buck passing too many times.

It's not buck passing. If we tell the graphics card to do a certain thing, and it decides for whatever reason not to, then that is buggy behavior in the card. It is of course possible that the bug is on our side, I will not discount it altogether, but considering the situations in which it happens it seems unlikely, and we have not been able to find a reason for it.


Quote
I have 100's of games and every single one works fine on my system

Most of which probably use DirectX, rather than OpenGL (of which ATI's implementation is known to be substandard).

Quote
we do not know how to fix it at this time, but we Are investigating how to fix it

It's not something we can fix. We could make a work around if we knew what was causing it, and it was something we could avoid, neither of which we know.

Quote
Keep those logs coming in to help us.

The logs are unaffected by this issue, so they aren't helpful.

Trust me, if there was a way for us to investigate this further short of buying random ATI cards and hoping we can somehow trigger it, we would do so.

orzelek

  • Distracted
  • ***
  • Posts: 258
  • Karma: +28/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #21 on: April 25, 2011, 06:54:18 AM »
I'll just add that I have an ATI (4870) and I did not disable the Catalyst AI and I don't recall having any graphical issues. Unless I'm not noticing the difference...

ouch

  • Distracted
  • ***
  • Posts: 216
  • Karma: +17/-1
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #22 on: April 25, 2011, 07:21:37 PM »
my old hd3850 had this problem, my new hd6970 does not.

The problem may very well be in the instruction engine on the silicon. Wouldn't be the first time it happened.
My Mods:
Auto Resource Transfering Subsystems (Fuel, Power, Ammo):
http://forums.blind-mind.com/index.php?topic=1427.0
Advanced spiral universe generation:
http://forums.blind-mind.com/index.php?topic=1536.0
Currently working on: Adv Spiral Universe Map

cynric

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-3
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #23 on: April 26, 2011, 12:37:55 AM »
It's also the truth, so I'm not sure what you're getting at here.

Disregarde that comment it was personal and in no way constructive to the issue at hand.

I would love to hear your way of fixing it, it would be implemented instantly.

If I were to attempt a fix to this, I would contact ATI, and get a Direct Quote from them, even if that Quote is Silence. Once that was obtained, I would pass that along to the gamers. That way I as a gamer know you have done all you can do on your end then I can go bug ATI about it :). If however the answer is not silence but it is an error on your side you can then at the very least give new news on progress instead of a flat out no it can't be done.

Most of which probably use DirectX, rather than OpenGL (of which ATI's implementation is known to be substandard).

My game Library goes back to Commodre 64, so i am sure i have enough that run both DirectX and OpenGL, I was unable to find any information that ATI is substandard on OpenGL perhaps u could give me a link to this information.

It's not something we can fix. We could make a work around if we knew what was causing it, and it was something we could avoid, neither of which we know.

This response is much better then it Can't be done. thank you

The logs are unaffected by this issue, so they aren't helpful.

good to know

Trust me, if there was a way for us to investigate this further short of buying random ATI cards and hoping we can somehow trigger it, we would do so.

I belive you, and I do appreciate all the quick fixes you guys do get out there, again sorry if i sound ungrateful, but you made a fantastic game and I get annoyed when i cannot play it in all its glory :)

chemicalderrick

  • Newbie
  • *
  • Posts: 31
  • Karma: +2/-2
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #24 on: June 07, 2011, 03:07:33 AM »
This might be considered ranting, but you, sir, are sliding towards troll-level.

I am a hobby programmer myself and even if my skills are not even close to the creators of this awesome piece of work, you will allow me to introduce you to an extremely simplified model on how games actually work. Or do not work.

A game-engine, which is kind of the base for the game, the Unreal-engine is an example, is composed of different, forgive me, sub-engines. Sound-engine, input-reading and of course the Graphics.
However, the Graphics engine itself has to communicate with the videocard. Thats where Application Programming Interfaces (API) join the party. These APIs provide a higher-level access to the videocard's features, such as 3D displaying, texturing, shaders and other stuff that the consumer does not have to deal with. You'll just want to make sure to have the necessary software (drivers for your videocard and the runtime for the API) installed.

Examples for these APIs are Direct3D (part of the DirectX APIs) and OpenGL. Now, if the engine tells the API to, lets say, put a texture on a model it will hand these tasks down to the lower level parts of graphics processing. The driver will then "contact" (as I said, it is extremely simplified and might even be wrong in some parts. But this is an explanation for the consumer ;)) the video card.

However, the driver OR the videocard itself might say "No, I won't put the texture on the model." or, even worse, "How do I do that?".
This is NOT the fault of the guy creating the game but the company deciding to not include an implementation of this feature in their drivers. Or fuck up the implementation itself.

I hope I managed to hammer that into your mind now. If the problem is in the drivers, feel free to help us out by writing your own fully featured driver. If you take feature requests let me know. Or, even better, write a clone of SR using DirectX.
Also, if you want them to buy random ATi-cards and spend their time AND their money on trying to fix a problem they most likely cannot fix at all. If you would donate these cards, that would be a completely different story.

If you want a workaround right now: Buy an nVidia-card. I once had an ATi-card, was some HD 4xxx. I had issues with almost any OpenGL app, WurmOnline and Typhoon2001 to name two of them, because ATi's OpenGL-implementation SUCKS.

I am really sorry if I pissed anyone else off, but I really DETEST people who do not want to understand when something is not possible nor want to help and fix the problem.

EDIT: I also am aware that the last answer was given one month ago.
Greetz

chemicalderrick

cynric

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-3
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #25 on: June 14, 2011, 12:34:05 AM »
I am not even a hobby programmer, however simple logic dictates that if every other game I have runs fine on ATI and this single one game does not, then logically I will conclude it is the game that has the issue. Since my game library is extensive, I have a large base to compare this against.

While my responses were designed to help solve the problem, all your's is doing is inflaming it by in no small way calling me dense. I belive that is the true definition of trolling. I did notice that my suggestion to contact ATI to help with the issue went unanswered, that was a clear and concise way to solve the issue. This points towards the owners being biased towards a certain card, Nvidia.

According to Steam, 40% of steam users use ATI, if we only look at the steam platform, why would any company trying to make money, alienate 40% of there clientell?
Well if all my efforts to help resolve the ATI issue by offering my input is trolling then i withdraw my input.
I gladly uninstall this game and wash my hands of it, there are plenty of games out there that do work on ATI, instead of switching cards i will just switch games and make sure I never invest in this company again.

Sorry for wasting everyones time.

Firgof

  • BMS Administrator
  • Delusional
  • *
  • Posts: 1531
  • Karma: +175/-4
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #26 on: June 14, 2011, 01:51:27 AM »
I am heartened to hear that there are those who regard us as titans, able to shake the heavens of hardware manufacturers with but scant words and shaking fists: "We are Blind Mind Studios and we demand satisfaction!"

Yet, sadly, we must live on this planet Earth where 3-person LLCs which have less than 40k users hold not enough sway to force major corporations to spend $10Ks to $100Ks to solve problems regarding an optional, non-standard, card-specific feature which can already be worked around with a simple click of a mouse: the solution being a complete reimplementation of a complex and large rendering platform and a plethora of readily-offered diagnostic tools.

I do have some good facts of my own if you'd like to peruse them:
Fact one: Most games (likely including the majority of your library) run on DirectX and when they do run on OpenGL they most likely run with simple shaders, are 2D, or both.
Fact two:  We are not 40% of Steam's or ATI's clientele.
Fact three:  We at Blind Mind Studios are not trolling you; your reaction to other users your own.

We hope you do continue to enjoy DirectX instead of switching cards or contacting ATI to verify if what we said was true: ignoring the underlying problem, punishing us, and ignoring/rewarding the company who has given you cause for this vitriol in one fell swoop.  If you are, however, hungry for information Google stands at the ready as it stood while you wrote your post: http://www.google.com/search?q=OpenGL+ATI+substandard . Let this link be the beginning of a personal revelation.

We regret that you will not invest in our titles or games and hope that you employ more patience and simple logic in the future before jumping to inflammatory, divisive, (and if I may say "Substandard") conclusions.
« Last Edit: June 14, 2011, 03:20:24 AM by Firgof »
"Now it will punish you"

orzelek

  • Distracted
  • ***
  • Posts: 258
  • Karma: +28/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #27 on: June 14, 2011, 12:34:37 PM »
I looked at that google results... and sadly most of them are quite old.

And after change of graphical card text in Star Ruler became blurred... and main advice of this thread is sadly no longer applicable - there is no way to disable Catalyst AI.
And settings there don't help - they kind of cut on settings I think recently since I recall having more options before.

Firgof

  • BMS Administrator
  • Delusional
  • *
  • Posts: 1531
  • Karma: +175/-4
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #28 on: June 14, 2011, 12:38:22 PM »
Change the search filter settings to 1 year if you'd like.  ATI has a long and storied history of poor OpenGL support.  Feel free to play with search terms, for instance: ATI doesn't support OpenGL

I'm annoyed to hear that they've disabled the means to disable Catalyst AI but unsure what I can do to help.
Surely they must have some means to disable it still...

Regardless:  You should contact them and complain that they've disabled the ability to disable a feature that must be disabled for one of your games to work properly.
« Last Edit: June 14, 2011, 12:44:24 PM by Firgof »
"Now it will punish you"

orzelek

  • Distracted
  • ***
  • Posts: 258
  • Karma: +28/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #29 on: June 28, 2011, 01:08:19 PM »
I tried to play around with google and found a way to disable catalyst AI. It doesn't help with the issue - my menus are still blurred and some of GUI elements are distorted a bit. Do you have any other ideas what can cause this?

Main thing that changed would be the OpenGL version - it's OpenGL 4 now vs OpenGL 3 earlier. I can attach screen-shot if needed. I also tried to change options in Star Ruler itself but disabled shaders and anti-aliasing don't change anything.

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: [ATI Users] Disable Catalyst AI
« Reply #30 on: June 28, 2011, 01:14:55 PM »
A screenshot would help. It sounds like your textures are being forcefully rescaled by the drivers, even though we specifically avoided that known issue with ATI when creating GUI assets.

orzelek

  • Distracted
  • ***
  • Posts: 258
  • Karma: +28/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #31 on: June 28, 2011, 01:21:12 PM »
Strange thing is that none of options available in game and in drivers seem to affect this effect.
And the distortion itself changes when window is moved around the screen.
Letter blurring seems to disregard screen position.

Edit: My GPU is Radeon 6950
« Last Edit: June 30, 2011, 05:28:27 AM by orzelek »

fxfighter

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #32 on: June 29, 2011, 06:30:33 PM »
That's the same issue I have by the looks and it makes the game pretty much unplayable as I start to get a headache after attempting to read the blurry text for a bit. (2x 6970s)

systemscrash

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #33 on: July 09, 2011, 06:06:55 PM »
this new version (1.0.8.2) broke parts of my UI, before if i turned catalyst ai, i could see all the icons i need to play the game. Now i cant see them even if i disable it.

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: [ATI Users] Disable Catalyst AI
« Reply #34 on: July 09, 2011, 10:38:01 PM »
this new version (1.0.8.2) broke parts of my UI, before if i turned catalyst ai, i could see all the icons i need to play the game. Now i cant see them even if i disable it.

If you installed the patch to the Steam version, that's the problem - it isn't fully compatible. If you didn't, I recommend reinstalling, and redownloading recent patches.

systemscrash

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #35 on: July 09, 2011, 11:47:57 PM »
Its fixed, thank you.

Valerian

  • Newbie
  • *
  • Posts: 33
  • Karma: +1/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #36 on: July 13, 2011, 10:25:49 PM »
This game looks great ! But sadly i have an ATI card :/

My card is an HD 5770 on win7 64, and i experience the most common problem with ATI cards : planet and ship icons disappearing a few second after game start, or never appearing at all.
I also have the same disappearing problem with the green direction lines, either thoses showing the current ship course, and i cant even see the destination height line even by holding CTRL.
Those problems might not be linked because lines disappear a few seconds after icons.

Without lines and icons, quite hard to play ^^

I tried a lot of ATI settings, even completely disabling AI by editing profiles.xml (tutorial here : http://www.moddb.com/mods/perfected-doom-3-version-500/features/how-to-disable-catalyst-ai-with-the-latest-ccc) but nothing changed at all.

Finally I managed to find some kind of workaround by putting an older atioglxx.dll in star ruler folder, from old catalyst drivers (9.11).
It partially correct the problem, by replacing the missing icons with some random garbled texture, changing with each game session, and lines are present but barely visible (might be an antialiasing issue, i still have to make some tests).

here is a screenshot with planets on background and some cruisers on foreground :


Uploaded with ImageShack.us

if needed the catalyst 9.11 win7/vista 64bit dll i am using : atioglxx.dll - 2.5 Mb

with 9.10 and previous drivers the game will not be able to launch, and starting from 9.12 up to 11.6 the bugs are still there :/



Would it be possible to provide a command-line option for choosing opengl version, or maybe even other irrlicht versions if possible ?
If you could make a simple compatibility mode by trying to use different ways of rendering lines and icons that might do the trick !

I am open to anything to help you resolving this issue, and i am sure that a lot of people in the community would gladly make a donation to get you an ATI card ^^.

In the meantime i think i will try to buy a secondhand geforce card :/ ...

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: [ATI Users] Disable Catalyst AI
« Reply #37 on: July 13, 2011, 10:41:41 PM »
I don't think it is possible to use an older version of OpenGL. The program simply asks the graphics card what version is running, and any available addons for various rendering utilities.

Do the icons still render incorrectly with shaders disabled?

Valerian

  • Newbie
  • *
  • Posts: 33
  • Karma: +1/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #38 on: July 13, 2011, 11:12:36 PM »
I tried a lot of settings, and of course minimal settings with shader disabled, still no change :/

If that can help you, i have no icons at all with shader disabled on my downgraded driver.
« Last Edit: July 13, 2011, 11:15:10 PM by Valerian »

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: [ATI Users] Disable Catalyst AI
« Reply #39 on: July 13, 2011, 11:41:15 PM »
Unfortunately, that just makes it worse. If even no-shaders exhibits the problem, I can't even begin to guess how to solve it.

Valerian

  • Newbie
  • *
  • Posts: 33
  • Karma: +1/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #40 on: July 17, 2011, 11:11:24 AM »
I just completely downgraded my drivers to catalyst 10.4 which is known as a good version for opengl, it now works perfectly, and i even have better performance !
(with catalyst AI off, of course)

Maybe it is due to ATI including opengl 4.1 support in 10.12 drivers, so when Star Ruler engine switches to 4.1 it is not working as intended.
I may try 10.11 someday, but now i do not feel the need to change and i am tired of spending my whole day fixing opengl ^^

greywolf

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #41 on: July 26, 2011, 02:33:23 AM »
Just saw this discussion. I know that Star Ruler works well at least on 2 very different PCs with an ATI card (a big Vista desktop with an AMD processor, and an old IBM Intel Thinkpad running under XP). The thread tells very mixed stories, too, about SR working or not working on various PCs with ATI cards. My conclusion is that the problem cause is very likely not ATI, or at least not ATI alone, but possibly ATI plus something else.
How about leaving the history of how bad ATI and OpenGL work together aside (or continuing the debate elsewhere), and focussing on the problem and its solution instead?
Before anyone asks: I myself can’t help. Just felt sorry about a discussion going wrong in my mind.

Firgof

  • BMS Administrator
  • Delusional
  • *
  • Posts: 1531
  • Karma: +175/-4
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #42 on: July 26, 2011, 02:59:36 AM »
The problem with the problem is that what we've got is a murder mystery without any remaining leads; just vague hints that point in various directions but at nothing in particular.  All our usual diagnostic tools are useless and give us no relevant information.  We've looked at our usual suspects but have come up with nothing.  If there's something wrong with ATI's implementation of a particular set of instructions within the context of GLSL we would be unable to locate it as they've gone "rogue" from the standard.  We would need to ask them for their full implementation of GLSL: something they're not willing to casually hand out I'd wager or be unable to if it varies from card to card.

Also: we have no proof to bring to them, so we are likely to simply be dismissed.  Looking historically and to what has 'fixed' the problem to some degree in the past and present: ATI is a strong suspect.  That Catalyst AI being turned off prevents a large score of problems with rendering in Star Ruler on some of ATI's cards works means that there's something at the very least wrong there, if not outright faulty.  But even if we knew it was a problem with Catalyst AI, we couldn't likely do anything to prevent it on our end.  We don't know anything about Catalyst AI or how it's programmed; or how it's causing the problem.  It's a black box that we'd have to prod for a long time to  figure it out.  By the time we did we'd be many versions out of date thus wasting everyone's time.  That's optimistic as I'm assuming that every Catalyst AI implementation is the same.

This is not even looking at user hardware/software interaction.  If there's something wrong with how something is interacting with something else we would need to borrow their computer as it would be impossible to extremely difficult to replicate their issue without their setup.  Even then:  It may be something we can do nothing about.  For example: missing shader instructions from custom implementations of GLSL.  Or Operating System errors.  Or strange interactions with Antivirus software and so on.

The problem with the problem is that there is no one solution.  If we knew what was going on here, we'd have already fixed this problem.  We've already put a lot of time into deciphering it and got nowhere in a hurry.  In the end, it comes down to:  Wheel our legs and try to find purchase on this enigma (and possibly not be even able to fix it) or work on Star Ruler like we said we would.

It's aggravating for us (as I'm sure it's aggravating to those affected by these issues) but despite our best efforts, we've learned nothing about the underlying problem and can't justify the time investment taken away from Star Ruler's development for what may be a wild goose chase.
« Last Edit: July 26, 2011, 03:17:10 AM by Firgof »
"Now it will punish you"

orzelek

  • Distracted
  • ***
  • Posts: 258
  • Karma: +28/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #43 on: August 21, 2011, 05:24:39 AM »
Short note: installing of Catalyst 11.8 seems to fix the blurring problem I had with text. Nothing about OpenGL fixes was mention in it's release notes... but it seems someone noticed the issue and fixed it at least.

NeedHelp

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: [ATI Users] Disable Catalyst AI
« Reply #44 on: August 31, 2011, 01:41:39 PM »
for those who are having problems disabling AI use this program..

http://www.radeonpro.info/en-US/

You can set up a profile that will disable it.

It did not work for me but it may work for others

Good luck and best wishes to developers.