Author Topic: Galactic Mod not working on newly downloaded game is it v1.0?  (Read 761 times)

Makadelik

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
I recently downloaded my old fav 4x game from game fly. The file I downloads from gamefly is "StarRuler_1.0_ddsetup"

I also noticed the version it installed does not have the button on the main screen to "check for updates" Does this mean that I have version 1 and that's why the latest version of Galactic Armory doesn't work? I'm going to try again. The mod shows in the list, but when i try to start a new game it says "Could not load mod Galactic Armory 1.9.4. missing"

I'll give attempting manual updates from version 1 to the current version tonight or tomorrow.

Let me know if you have any tips. I was hoping to have a little fun this weekend : p

Thy Reaper

  • BMS Lead Developer
  • BMS Administrator
  • Hopeless
  • *
  • Posts: 3237
  • Karma: +397/-8
    • View Profile
    • Blind Mind Studios
Re: Galactic Mod not working on newly downloaded game is it v1.0?
« Reply #1 on: July 12, 2014, 12:30:12 AM »
None of the distributors should have that build any more. Sounds like Direct2Drive did something wrong when they moved stuff over to Gamefly. You can download patches here: http://starruler.blind-mind.com/list_patches.php?v=1000

Install them in order. I'm not sure which version added the auto patcher, should be 1.0.7.4. At that point you can have the game finish updating.

You can also just email me at admin@blind-mind.com with a proof of purchase, and I'll send you a Steam key.
« Last Edit: July 12, 2014, 12:34:13 AM by Thy Reaper »

Makadelik

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Galactic Mod not working on newly downloaded game is it v1.0?
« Reply #2 on: July 12, 2014, 12:37:47 AM »
Oh my. Thank you! After 16 patches its working

I thought it looked "funny" when I loaded it. it was version 1.0.0 : p